Installer Dwarf Fortress sur une Linux Mint Debian 64bits

Rédigé par salelodenouye le 20 janvier 2013

Je l'avais essayé il y a quelques temps, mais il est vrai que ce jeux est assez difficile à prendre en main car très complet.

Ce Week End il faisait moche dehors, donc je me suis dis que j'allais y rejouer un peu..pas de bol sous Linux il ne fonctionnait pas.

J'ai donc passé quelques heures à chercher pourquoi.

Au début j'ai eu une erreur pas trop grave que j'ai pu solutionner après une recherche rapide sur le net. Il fallait installer le package libsdl-image1.2 car je rencontrais l'erreur ci-dessous :

error while loading shared libraries: libSDL_image-1.2.so.0

En revanche l'erreur suivante m'a donné plus de fil à retordre :

./libs/Dwarf_Fortress: error while loading shared libraries: libGL.so.1: 
cannot open shared object file: No such file or directory

En fouinant sur le net j'ai cru comprendre qu'il s'agissait d'une erreur plus ou moins due au fait que Dwarf Fortress ne pointe pas vers les bon chemins sur les architecture 64 bits.

Une conversation sur un forum m'a mis sur la piste en m'indiquant la variable qu'il fallait modifier pour que l'executable puisse récupérer la librairie au bon endroit.

Seulement je ne sais pas si ça vient de ma Linux Mint ou si c'est le post qui est ancien, mais ça ne fonctionnait toujours pas. En effet le répertoire indiqué par le forum n'existe pas sur mon PC.

En faisant un find, j'ai pu donc trouver où était stocké la fameuse librairie manquante et au final en lancant le jeu avec cette commande, ça marche =) :

LD_LIBRARY_PATH=/usr/lib/mesa-diverted/i386-linux-gnu/ ./df

 

Classé dans : Linux, - Mots clés : Dwarf Fortress -

Installation XMPP pour Jappix : eJabberd

Rédigé par salelodenouye le 05 octobre 2012

Cet article est encore en cours de rédaction...il y a des petites choses à améliorer comme le serveur multicanal et le pubsub

Lire la suite de Installation XMPP pour Jappix : eJabberd

Classé dans : Des InternetsLinux, - Mots clés : aucun - aucun commentaire

apt-get powwaa !!!

Rédigé par salelodenouye le 03 octobre 2012

Décidément on en apprends tous les jours...cette fois-ci après avoir manqué de chibrer un container en faisant une mise à jour abusive, me voila obligé de vérifier les différences entre mon container et ma sauvegarde.
J'ai fais ma comparaison avec rdiff-backup, du coup je sais quels fichiers sont nouveau ou supprimés, les modifiés ne m'intéressent pas dans ce cas..

 

Retrouver le package à partir d'un fichier

Par contre une fois les fichiers modifiés repérés il faut supprimer le package associé. Pour ça il suffit il y a une commande :

dpkg -S /le/nom/du/fichier

 

Lister tous les packages installés

Après cette méthode bien que très utile et vraiment pratique ne m'est pas d'un grand secours. D'autant plus que je dispose du container /avant du coup je vais le faire tourner juste pour lancer une commande :

dpkg --get-selections

Cette commande renvoit la liste de TOUS les packages installés ! je n'ai plus qu'à faire un diff de mes 2 listes de packages :)
 

Classé dans : Linux, - Mots clés : apt-get debian linux - aucun commentaire

Installation d'un serveur Bosh pour Jappix grâce à Prosody

Rédigé par salelodenouye le 30 septembre 2012

Je me suis amusé à installer un serveur XMPP chez moi ce WE...j'en ai trouvé un petit, léger et qui fait pas mal de chose : Prosody.

Prosody fonctionne vraiment bien et est très simple d'utilisation. Du coup pour continuer sur ma lancée, j'ai voulu installer Jappix.

Rien de compliqué à première vue car Jappix donne des tutoriels pour installer Jappix avec Prosody et le proxy Bosh configuré.

https://github.com/jappix/jappix/wiki

Sauf que j'ai buté sur un des aspects de Prosody...
Dans le fichier de configuration il y a des sections...ça parait bête comme ça, mais elles ne sont pas indiquées (si ce n'est par les commentaires).

J'ai donc passé une bonne partie de mon samedi à tourner en rond car je n'arrivais pas à faire marcher le proxy Bosh. J'obtenais l'erreur ci-dessous :

error: proxy: error reading status line from remote server

En effet j'utilisais un port spécifique. En réutilisant le port par défaut le lendemain, j'ai réussi à passer à une autre erreur (depuis Jappix cette fois-ci) :

Error » Encryption (SSL or TLS) is required to connect to this server

En déplacant les ligne de paramétrage au bon endroit le lendemain, ça marchait beaucoup mieux !!
Du coup j'ai gardé le port par défaut, mais je suppose qu'elle avait la même origine.

 

Installation d'une passerelle vers les autres protocoles

J'utilise un petit serveur avec un processeur atom chez moi. Pour essayer de cloisonner un max le serveur entre les services que je fais tourner h24 et le "mediacenter" j'utilise lxc. Cet outils me permet de créer des conteneur sans pour autant avoir à virtualiser complètement une nouvelle machine. C'est vraiment pratique et très simple à mettre en place.

Par contre je crois que je viens de rencontrer une des limite de LXC qui m'empêche d'installer libpurple (une usine à gaz permettant de faire fonctionner les passerelles sur Prosody)

Classé dans : Des InternetsLinux, - Mots clés : aucun - aucun commentaire

Shaarli

Rédigé par salelodenouye le 29 septembre 2012

Il y a des outils que l'ont juge inadaptés (comme se fut le cas pour Dotclear), et il y a les autres. =)

Shaarli a été développé il y a quelques temps par sebsauvage c'est un outils très simple et bigrement efficace.

D'ailleurs je suis toujours scotché au flux RSS de sebsauvage. Et j'ai aussi installé shaarli chez moi pour gérer les liens et/ou des notes que je veux conserver.
Shaarli m'a déjà fais gagner un temps précieux à de nombreuse reprises :

  • Pour retrouver un article, un logiciel ou un tutoriel oublié
  • Pour retrouver une commande UNIX oubliée
  • etc

 

Classé dans : Des Internets, - Mots clés : sebsauvage shaarli rss - aucun commentaire

page 1 sur 2 suivante